Carrier Partner Incident - SMS - Route 2 - United Kingdom - Lebara

Incident Report for SMS Magic

Resolved

Monitoring for the issue impacting SMS services for United Kingdom - Lebara has concluded and confirmed that previously impacted services have been restored to pre-incident health.
End Time : May 14, 06:10 PDT
Posted May 14, 2026 - 13:14 UTC

Investigating

Start Time : May 14, 2026 - 03:55 PDT
There is a carrier-partner incident currently impacting SMS services (route 2) in United Kingdom - Lebara.
Customers may experience intermittent delay impacting inbound (MO) and outbound (MT) SMS and delivery receipts.
The cause of this issue is under investigation at this time.
Posted May 14, 2026 - 12:50 UTC
This incident affected: SMS Magic Europe Data Center (Message Delivery Service) and SMS Magic US Data Center (Message Delivery Service).