SMS Magic Delay in incoming message service hosted in the US data center
Incident Report for SMS Magic
Resolved
Resolution:
This was happened due to the Salesforce Maintenance ( https://status.salesforce.com/generalmessages/766 ) at their end. Due to this when we are syncing the messages to the Salesforce, it takes 10-15 seconds almost (usually this syncing happens approx. 1 sec).

Because of this delay rate, messages are queued up in SMS-Magic servers and get processed at a slow rate.

This got resolved automatically once the Salesforce Maintenance got completed.

There were no changes done at SMS-Magic's end for this incident.

Duration for the outage:
Start time: 1st Sep 2021 17:30 UTC
End time: 1st Sep 2021 22:30 UTC
Posted Sep 08, 2021 - 12:27 UTC
Investigating
Issue:
We are experiencing a delay in processing incoming messages with SalesForce for some instances. This issue has been observed specifically with SalesForce.

Impact:
Delay in receiving incoming messages in Salesforce

Resolution:
We are investigating the cause for this and we will post the analysis at the earliest.

Data Center - US
Posted Sep 01, 2021 - 20:18 UTC
This incident affected: SMS Magic US Data Center (Incoming Message Sync with Salesforce).