UK SMS - Planned maintenance affecting BT network

Scheduled for May 21, 21:00 UTC  -  May 22, 03:00 UTC

Update

Upcoming scheduled maintenance notice

Between 21.05.2026 21:00 UTC and 22.052026 03:00 UTC, UK Mobile operator BT will be performing maintenance on their SMS platform.

During this maintenance period, there may be difficulties in delivering messages to subscribers of this operator.

If you have any questions, please contact care@screen-magic.com
Posted May 20, 2026 - 11:13 UTC

Scheduled

Upcoming scheduled maintenance notice

Between 21.05.2026 21:00 UTC and 22.052026 03:00 UTC, UK Mobile operator BT will be performing maintenance on their SMS platform.

During this maintenance period, there may be difficulties in delivering messages to subscribers of this operator.

If you have any questions, please contact care@screen-magic.com
Posted May 20, 2026 - 09:01 UTC
This scheduled maintenance affects: SMS Magic Europe Data Center (Message Delivery Service, Incoming messages) and SMS Magic US Data Center (Message Delivery Service, Incoming messages).