SMS Channel Degradation

Incident Report for SMS Magic

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 04:09 UTC

Investigating

New incident: Investigating
We are aware of issues that may be impacting your SMS services

Our providers are working to quickly resolve the issue. We’ll provide further updates within 90 minutes.

Thank you for your patience and understanding.

If you have any questions, please contact care@screen-magic.com
Posted Jun 26, 2026 - 02:17 UTC
This incident affected: SMS Magic Australia Data Center (Message Delivery Service, Incoming messages), SMS Magic Europe Data Center (Message Delivery Service, Incoming messages), and SMS Magic US Data Center (Message Delivery Service, Incoming messages).