MMS Delivery Delays to AT&T Destinations

Incident Report for SMS Magic

Resolved

MMS delivery to AT&T destinations have returned to normal latency
The issue is resolved.
Posted Sep 23, 2026 - 20:17 UTC

Investigating

We have received a notification regarding delayed MMS delivery to AT&T destinations. Messages are being delivered, but with delays.
SMS to AT&T and MMS to other carriers are unaffected.
The issue is currently under investigation.
Posted Sep 23, 2026 - 17:06 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).