Carrier T-Mobile – Unplanned Maintenance SMS & MMS Delivery Impact

Incident Report for SMS Magic

Resolved

The maintenance has been completed.
If you continue to notice any discrepancy, please reach out to care@screen-magic.com
Posted Sep 09, 2025 - 12:03 UTC

Identified

Start Time: Sept 9, 2:00 AM UTC
End Time: Sept 9, 12:00 PM UTC
Impact: Partial Outage – Message Delivery Failures

Description:
T-Mobile has scheduled unplanned maintenance on their short-code delivery hub and toll-free delivery hub from September 9, 2025, 2:00 AM UTC. During this time, outgoing SMS and MMS messages may experience intermittent delays or failures.
We are following up with the provider and closely monitoring from our end.

Next Update: We will provide an update as soon as more information becomes available.
We apologize for the inconvenience.
Posted Sep 09, 2025 - 06:44 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service, Incoming messages).