SMS Delivery Delays and Failures to Altice United States

Incident Report for SMS Magic

Monitoring

We have observed a recovery in SMS delivery to Altice (CSC Wireless) network subscribers in the United States and are monitoring service stability.
Posted Aug 28, 2026 - 20:48 UTC

Investigating

We have received a notification from our provider regarding SMS delivery delays and failures to Altice network subscribers in the United States. We will provide another update as soon as more information becomes available.
Start Time : Aug 28, 09:52 PDT
Posted Aug 28, 2026 - 17:09 UTC
This incident affects: SMS Magic US Data Center (Message Delivery Service).