DEGRADATION - Delayed Message Processing and Delivery Updates for US DataCenter

Incident Report for SMS Magic

Resolved

All platform operations are now back to normal.
Posted Nov 26, 2025 - 20:13 UTC

Monitoring

CURRENT UPDATE:
Issue was identified due to message component failure. This has been recovered and normal processing has been restored.
We are continuing to closely monitor the system.

DURATION
START TIME: 5PM UTC
END TIME: 7:30PM UTC
Posted Nov 26, 2025 - 19:48 UTC

Investigating

ISSUE:
Our Support team has identified database performance issue. Engineeering team has been engaged and currently investigating.

IMPACT:
Customers would see a delay in both incoming as well as outgoing message processing as well as delivery updates.

DURATION
START TIME: 5PM UTC

NEXT UPDATE: 7:00PM UTC
Posted Nov 26, 2025 - 18:56 UTC
This incident affected: SMS Magic US Data Center (Salesforce API, Message Delivery Service, DLR Sync with Salesforce, Incoming Message Sync with Salesforce, Incoming messages).