Message delivery issue - Global outage

Incident Report for SMS Magic

Resolved

A fix has been implemented and we are monitoring the traffic.
The issue is now resolved.
Posted Mar 11, 2026 - 19:33 UTC

Update

We are continuing to investigate this issue.
Posted Mar 11, 2026 - 15:25 UTC

Investigating

We are currently experiencing a global issue impacting multiple customers.
The delivery status is not getting updated and the messages continue to reflect in the submitted state.
The issue is identified and the Engineering team is actively working to resolve it as soon as possible.
Posted Mar 11, 2026 - 15:23 UTC
This incident affected: SMS Magic Europe Data Center (Message Delivery Service) and SMS Magic US Data Center (Message Delivery Service).