MMS media content towards T-Mobile destinations are displaying improperly

Incident Report for SMS Magic

Resolved

This incident has been resolved.

End Time : Jan 22, 22:30 UTC
Posted Jan 23, 2026 - 12:59 UTC

Investigating

We have received a notification from our Provider regarding MMS media contents not displaying properly on T Mobile destinations.
The issue is currently under investigation.

Start Time : Jan 22, 19:43 UTC
Posted Jan 22, 2026 - 20:04 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).