Long Code Service Degradation - Delay in Delivery

Incident Report for SMS Magic

Resolved

The 10DLC delivery hub has confirmed this issue has been resolved
End Time : Oct 07, 2025 - 07:59 CDT
Posted Oct 07, 2025 - 13:07 UTC

Investigating

Start Time: Oct 06, 2025 - 14:46 CDT
The 10DLC delivery hub has detected an issue resulting in intermittent delivery delays for SMS and MMS MO/MT/DLR.
Next Update: We will provide an update as soon as more information becomes available.
Posted Oct 06, 2025 - 19:58 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).