Delivery Issue Australia - Telstra

Incident Report for SMS Magic

Update

Telstra continues to investigate this issue.
Jul 8, 01:34 UTC
Posted Jul 08, 2026 - 02:59 UTC

Investigating

We are currently observing delivery issues in Australia - Telstra

Service impacted: Delays to processing of some Telstra port messages impacting Port Out transactions

Incident Start Time: 2026-07-07 21:22 UTC
Next update: 2026-07-08 00:22 UTC

We will update as soon as we have more information.
Posted Jul 08, 2026 - 02:57 UTC
This incident affects: SMS Magic Australia Data Center (Message Delivery Service).