Issues Creating New Links - Link Shortening Functionality

Incident Report for SMS Magic

Resolved

This incident has been fully resolved. The link creation API is operating normally and the underlying cause has been addressed.
End Time : May 12, 20:28 UTC
Posted May 12, 2026 - 20:30 UTC

Monitoring

We have received an update that a fix is now implemented and the performance is been monitored.
May 12, 2026 - 19:44 UTC
Posted May 12, 2026 - 19:51 UTC

Investigating

Start Time : May 12, 2026 - 17:45 UTC
We have received a notification from our Provider regarding a partial service disruption affecting our link shortening capabilities.
Some customers may receive "permission denied" or "You don't have the permissions to create this link" responses when creating links via the API, and bulk creation requests may complete with fewer links than requested.
The cause of this issue is under investigation at this time.
Posted May 12, 2026 - 18:02 UTC
This incident affected: SMS Magic Europe Data Center (URL Shortening & Tracking), SMS Magic Australia Data Center (URL Shortening & Tracking), and SMS Magic US Data Center (URL Shortening & Tracking).