Disruption in SMS sending using Bandwidth Provider
Incident Report for SMS Magic
Postmortem

Issue: Disruption in SMS sending using Bandwidth Provider

Observation: We were getting HTTP 400 Bad Request error from the bandwidth provider called “"Ambiguous URI empty segment"

Root cause: Till 1:30PM UTC Bandwidth provider was accepting // in the URLs passed to them and after 1:30 PM UTC, they started rejecting the URLs because of which we were getting errors and the outgoing sms were failing.

Fix: At 5:30PM UTC, We fixed the issue to not send // in the URLs and everything is working fine.

Posted Feb 15, 2024 - 09:39 UTC

Resolved
Disruption in SMS sending using Bandwidth Provider. We were getting HTTP 400 Bad Request error from the bandwidth provider called “"Ambiguous URI empty segment" because of which we were getting errors and the outgoing sms were failing.
Posted Feb 14, 2024 - 14:00 UTC