Service Disruption impacting all Operations (US DataCenter Only)

Incident Report for SMS Magic

Monitoring

The underlying infrastructure is now running stable and all services have been recovered. Customers should experience stable operations.
Support team is closely monitoring the infrastructure and system performance.
Posted Mar 11, 2026 - 17:03 UTC

Identified

We are currently investigating a widespread service disruption impacting all operations across platform.

Our engineering teams have identified that the issue is related to instability within the underlying infrastructure layer, which is causing intermittent failures across services. As a result, some customers may experience delayed responses, failed actions, or intermittent availability when interacting with the platform.

IMPACT
- Intermittent service errors across multiple features
- Increased response times for some requests
- Certain actions may fail or not reflect immediately

CURRENT STATUS
Our infrastructure and platform teams are actively working to stabilize the Redis layer and mitigate the impact. We are also implementing safeguards to restore normal service behavior as quickly as possible.

We will provide the next update within 30 minutes or sooner if significant progress is made.

DURATION
Start Time: 2PM UTC
Posted Mar 11, 2026 - 15:34 UTC
This incident affects: SMS Magic US Data Center (SMS Magic REST API, Salesforce API, Zoho API, Message Delivery Service, DLR Sync with Salesforce, Incoming Message Sync with Salesforce, DLR sync with Zoho, DLR sync with Open API, Incoming sync with Zoho, Incoming sync with Open API, Converse Desk on SaaS Portal, SMS Magic Customer Portal, Incoming messages).