United Kingdom SMS - Degradation affecting Lycamobile

Incident Report for SMS Magic

Resolved

This incident has been resolved.
Posted May 29, 2026 - 12:54 UTC

Update

We are continuing to investigate this issue.
Posted May 28, 2026 - 11:21 UTC

Investigating

New incident: Investigating

We have observed degradation impacting message delivery to Lycamobile in the United Kingdom.

The carrier is aware of this issue and is investigating the root cause. We will issue an update as soon as more information becomes available.

Please contact care@screen-magic.com if you have any questions.
Posted May 28, 2026 - 11:20 UTC
This incident affected: SMS Magic Europe Data Center (Message Delivery Service, Incoming messages) and SMS Magic US Data Center (Message Delivery Service, Incoming messages).