SMS Delivery Delay for Isle of Man - Manx Telecom

Incident Report for SMS Magic

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 20:05 UTC

Update

Monitoring for the issue impacting SMS intermittent delivery delay has concluded and confirmed that previously impacted services have been restored to pre-incident health.
The issue is resolved at this time.
End Time : Mar 12, 13:01 PDT
Posted Mar 12, 2026 - 20:05 UTC

Investigating

Start Time : Mar 12, 2026 - 05:50 PDT
There is a vendor incident currently impacting SMS services for Isle of Man - Manx Telecom.
Customers may experience an intermittent delivery delay at this time.
The cause of this issue is currently under investigation.
Posted Mar 12, 2026 - 13:09 UTC
This incident affected: SMS Magic Europe Data Center (Message Delivery Service).