Carrier Partner Incident - Verizon Wireless SMS Delay

Incident Report for SMS Magic

Resolved

Monitoring for the issue impacting short code and 10 DLC SMS services has concluded and confirmed that previously impacted services have been restored to pre-incident health.
The issue is resolved at this time.
End Time : Mar 6, 07:59 PST
Posted Mar 06, 2026 - 16:23 UTC

Monitoring

We can observe that performance is restored and will continue to monitor for any further disturbances.
Mar 06, 2026 - 07:00 PST
Posted Mar 06, 2026 - 15:42 UTC

Investigating

Start Time : Mar 06, 2026 - 02:00 PST
There is a carrier-partner incident currently impacting short code and 10 DLC SMS services.
Customers may experience intermittent Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts impacting inbound (MO) and outbound (MT) SMS via short code / 10 DLC with Verizon Wireless.
The cause of this issue is under investigation at this time.
Posted Mar 06, 2026 - 14:20 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).