Upcoming Carrier Partner Planned Maintenance

Incident Report for SMS Magic

Resolved

The scheduled maintenance has been completed.
Posted Oct 02, 2025 - 08:55 UTC

Investigating

Start Time: Oct 1, 22:00 CDT

The 10DLC delivery hub will be performing a planned maintenance on October 1, 2025 at 10 PM CT. During this maintenance window, there may be intermittent connectivity drops and MO/MT queuing and latency for SMS and MMS.

Estimated Duration : 7 hours

Next Update: We will provide an update as soon as more information becomes available.
Posted Oct 01, 2025 - 19:48 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).