Carrier Partner Incident - MMS Delivery Delays

Incident Report for SMS Magic

Resolved

Monitoring for the issue impacting all sender types MMS services has concluded and confirmed that previously impacted services have been restored to pre-incident health.
The issue is resolved at this time.
End Time : Apr 20, 06:52 PDT
Posted Apr 20, 2026 - 14:20 UTC

Investigating

Start Time : Apr 20, 2026 - 04:54 PDT
There is a carrier-partner incident currently impacting all sender types MMS services.
Customers may experience minor delivery delays impacting inbound (MO) and outbound (MT) MMS via all sender types .
The cause of this issue is under investigation at this time.
Posted Apr 20, 2026 - 13:35 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).