UK SMS - Delivery degradation towards Vodafone network

Incident Report for SMS Magic

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 14:57 UTC

Update

We are continuing to investigate this issue.
Posted Jun 29, 2026 - 14:18 UTC

Investigating

We are currently observing SMS delivery degradation towards the Vodafone network. You may experience missing and delayed messages and delivery receipts for outbound messages.

We are monitoring closely to resolve the issue and will provide an update as soon as more information becomes available.

If you have any questions, please contact care@screen-magic.com.
Posted Jun 29, 2026 - 12:12 UTC
This incident affected: SMS Magic Europe Data Center (Message Delivery Service) and SMS Magic US Data Center (Message Delivery Service).