Carrier Partner Incident - 10Dlc SMS & MMS Latency

Incident Report for SMS Magic

Resolved

The issue impacting 10DLC SMS and MMS services for international numbers has concluded and confirmed that previously impacted services have been restored to pre-incident health.
The issue is resolved at this time.
End Time : Mar 23, 08:03 PDT
Posted Mar 23, 2026 - 15:08 UTC

Update

The issue continues to be under investigation.
We will continue to keep you posted regarding further update on the same.
Posted Mar 23, 2026 - 14:34 UTC

Investigating

Start Time : Mar 23, 2026 - 00:35 PDT
There is a carrier-partner incident currently impacting 10DLC SMS and MMS services for international numbers.
Customers may experience intermittent latency impacting inbound (MO) and outbound (MT) SMS and MMS via 10DLC .
The cause of this issue is under investigation at this time.
Posted Mar 23, 2026 - 13:25 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).