Carrier T-Mobile Short Code Service Degradation

Incident Report for SMS Magic

Resolved

The short code delivery hub has confirmed this issue has been resolved.
If you continue to notice any discrepancy, please reach out to care@screen-magic.com
Posted Sep 16, 2025 - 15:57 UTC

Identified

Start Time: Sep 16, 2025 - 3:09 PM UTC
Impact: Short Code Service Degradation - T-Mobile

Description:
The short code delivery hub has detected an issue resulting in message latency with T-Mobile. We will provide more information as it becomes available.
We are following up with the provider and closely monitoring from our end.

Next Update: We will provide an update as soon as more information becomes available.
Posted Sep 16, 2025 - 15:28 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).