SMS Delivery Failures to Multiple Networks in Multiple Countries - 7 July 2026

Incident Report for SMS Magic

Resolved

The incident has been resolved and SMS delivery is operating normally.
End Time : Jul 07, 2026 - 14:03 PDT
Posted Jul 07, 2026 - 21:16 UTC

Identified

The team has identified the cause, and is working to resolve the issue.
Posted Jul 07, 2026 - 16:25 UTC

Investigating

Start Time : Jul 7, 08:09 PDT
We have received a notification from one of our Provider regarding customers experiencing SMS delivery failures to multiple networks in multiple countries.
Our team is actively investigating this issue. We will provide another update as soon as more information becomes available.
Posted Jul 07, 2026 - 15:18 UTC
This incident affected: SMS Magic Australia Data Center (Message Delivery Service), SMS Magic Europe Data Center (Message Delivery Service), and SMS Magic US Data Center (Message Delivery Service).