Service Degradation - Message Latency - SMS/MMS

Incident Report for SMS Magic

Resolved

We are no longer observing message latency. The Engineering team implemented corrective action to restore normal operations. All services are now functioning as expected. We will continue to monitor the environment closely to ensure stability.
Posted Nov 07, 2025 - 12:37 UTC

Investigating

Start time : 10:45 AM PST

We have received received a notification from our Provider that a performance degradation is observed starting at 10:45 AM PST.
Customers may experience widespread message latency regarding SMS / MMS
The Engineering team is actively investigating the issue and working to restore normal service.

Next Update: We will provide an update as soon as more information becomes available.
We apologize for the inconvenience and appreciate your patience.
Posted Nov 06, 2025 - 20:04 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).