The pending balance updates for AUS customer accounts have now been completed. All usage between November 19, 8:30 AM UTC and November 20, 10:36 AM UTC has been successfully processed.
This incident has been resolved.
Posted Nov 20, 2025 - 19:35 UTC
Update
The pending balance updates for EU customer accounts have now been completed. All usage between November 20, 9:30 AM UTC and November 20, 10:36 AM UTC has been successfully processed.
Next update: We will share another update once the AUS balance processing is completed.
Posted Nov 20, 2025 - 19:12 UTC
Identified
Credit Balance issue has been identified and a temporarily fix applied. All customer balances are updating correctly since 10:36AM UTC. Balances updates for some customer accounts are pending for any usage during the following timeframes.
For AUS accounts - Usage between November 19, 8.30AM UTC to November 20, 10.36AM UTC for EU accounts - Usage between November 20, 9.30AM UTC to November 20, 10:36AM UTC
Our Engineering team is working on a fix to resolve the same.
Posted Nov 20, 2025 - 13:07 UTC
This incident affected: SMS Magic Australia Data Center (Billing & provisioning service) and SMS Magic Europe Data Center (Billing & provisioning service).