UK SMS - Delivery receipt degradation affecting multiple networks

Incident Report for SMS Magic

Resolved

This incident has been resolved.
End Time : Jun 29, 20:02 UTC
Posted Jun 29, 2026 - 20:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2026 - 19:19 UTC

Investigating

Start Time : Jun 29, 17:16 UTC
We have been notified about an issue impacting SMS messages to multiple networks. You may experience missing or delayed delivery receipts when sending to multiple networks in the UK.
We will issue an update as soon as more information becomes available.
Posted Jun 29, 2026 - 17:48 UTC
This incident affected: SMS Magic Europe Data Center (Message Delivery Service).