Carrier Partner Incident - T-Mobile Toll-Free SMS Delivery Delays

Incident Report for SMS Magic

Resolved

Monitoring for the issue impacting toll-free SMS services has concluded and confirmed that previously impacted services have been restored to pre-incident health. The issue is resolved at this time
End Time : Jul 9, 08:01 PDT
Posted Jul 09, 2026 - 15:03 UTC

Investigating

There is a carrier-partner incident currently impacting toll-free SMS services.
Customers may experience minor delivery delays impacting SMS via toll-free with T-Mobile.
The cause of this issue is under investigation at this time.
Start Time : Jul 09, 2026 - 02:30 PDT
Posted Jul 09, 2026 - 12:26 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).