Message delivery failure due to Cloudflare Global Network experiencing issues

Incident Report for SMS Magic

Resolved

Cloudfare has released a confirmation that a fix has been implemented and the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.

End Time : Nov 18, 2025 - 15:23 UTC
Posted Nov 18, 2025 - 15:25 UTC

Investigating

Start Time : Nov 18, 2025 - 11:48 UTC

We have received a notification from our Provider regarding message delivery failure as Cloudflare is experiencing an internal service degradation.

Next Update: We will provide an update as soon as more information becomes available.
We apologize for the inconvenience and appreciate your patience.
Posted Nov 18, 2025 - 14:00 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).