Carrier Partner Incident - SMS & MMS Latency - Route 2

Incident Report for SMS Magic

Monitoring

A fix has been implemented by carrier partner teams for the issue impacting all sender types SMS and MMS services.
At this time our carrier partner teams are actively monitoring and will provide additional details in the event of further developments regarding this incident, or will otherwise confirm issue resolution shortly.
Posted Apr 15, 2026 - 20:26 UTC

Investigating

Start Time : Apr 15, 2026 - 11:42 PDT
There is a carrier-partner incident currently impacting all sender types SMS and MMS services.
Customers may experience intermittent latency impacting inbound (MO) and outbound (MT) SMS and MMS via all sender types (Route 2).
The cause of this issue is under investigation at this time.
Posted Apr 15, 2026 - 19:09 UTC
This incident affects: SMS Magic US Data Center (Message Delivery Service).