Carrier Partner Incident – SMS Latency for Outbound US Traffic (Small U.S. Carriers)

Incident Report for SMS Magic

Resolved

Please be advised that the issue impacting outbound messages Small US Carriers has now been resolved.
End Time : Feb 23, 11:33 PST
Posted Feb 23, 2026 - 19:39 UTC

Investigating

Start Time : Feb 23, 2026 - 11:20 PST
We have received a notification regarding a carrier-partner incident currently impacting SMS services for US region
Customers may experience intermittent latency impacting outbound (MT) SMS via Small U.S. carriers.
The cause of this issue is under investigation at this time.
Posted Feb 23, 2026 - 19:24 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).