Carrier Partner Incident: Verizon SMS & MMS Latency (Long Code, Short Code and TFN)

Incident Report for SMS Magic

Resolved

The upstream carrier-partner has successfully resolved the issue affecting Verizon services. Our monitoring confirms that SMS and MMS message delivery latency has returned to normal levels. We appreciate your patience
Posted May 27, 2026 - 22:14 UTC

Investigating

We are currently investigating an upstream carrier-partner incident affecting Verizon services.

Customers may experience intermittent latency or delivery delays when sending outbound messages to Verizon subscribers. This issue is impacting both Short Code, Long Code, and TFN routes across both SMS and MMS channels.

Our carrier partner is actively working to isolate and resolve the root cause. We are monitoring the situation closely and will provide further updates as new information becomes available.
Posted May 27, 2026 - 17:39 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).