Toll-Free Service Degradation

Incident Report for SMS Magic

Resolved

The toll-free delivery hub has confirmed this incident has been resolved.

End Time : Oct 29, 14:52 CDT
Posted Oct 29, 2025 - 19:56 UTC

Monitoring

The toll-free delivery hub is observing recovery in SMS delivery to small US carriers. Engineers are currently monitoring any further developments at this time.
Posted Oct 29, 2025 - 18:26 UTC

Investigating

Start Time : Oct 29, 12:02 CDT

Description : The toll-free delivery hub is experiencing an issue resulting in SMS delivery delays to small US carriers. Engineers are currently working with the carriers for remediation.

Next Update: We will provide an update as soon as more information becomes available.
Posted Oct 29, 2025 - 17:11 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).