Delivery Issue USA - T-Mobile

Incident Report for SMS Magic

Resolved

The incident has been resolved and SMS and MMS delivery to T-Mobile network subscribers in the United States are operating normally.
End Time : 2026-07-13 18:34 UTC
Posted Jul 13, 2026 - 21:30 UTC

Monitoring

Our Provider have observed a recovery in delivery to T-Mobile network subscribers in the United States and are monitoring service stability.
Posted Jul 13, 2026 - 19:32 UTC

Identified

The cause has been identified and a fix is been implemented
Posted Jul 13, 2026 - 19:11 UTC

Investigating

We have received a notification from our Provider regarding delivery issues observed towards USA - T-Mobile.
Incident Start Time: 2026-07-13 14:59 UTC
Customer's might face Delayed Oubound/Delayed Inbound/Missing delivery receipts/Late delivery receipts
Posted Jul 13, 2026 - 15:58 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).