Carrier Partner Incident – Inbound SMS Latency (Short Code – Route 1)

Incident Report for SMS Magic

Resolved

Monitoring for the issue impacting Inbound (MO) SMS services via Short Code (Route 1) has concluded. We have confirmed that all services have been restored to full health.

Final Status: Resolved
Impact: Inbound SMS delays have been cleared.
Current State: All systems are operating normally.

We appreciate your patience while we worked with our carrier partner to resolve this.
Posted May 05, 2026 - 20:30 UTC

Investigating

We are currently investigating reports of delivery delays affecting inbound (MO) SMS messages via Short Code (Route 1).

The issue has been traced to a technical problem with one of our upstream carrier partners.

Please note: Outbound messaging services remain fully operational and unaffected.

Our team is actively working with the carrier partner to resolve the issue as quickly as possible. We will continue to share updates as more information becomes available.
Posted May 06, 2026 - 00:30 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).