Disruption in SMS sending using Twilio Provider
Incident Report for SMS Magic
Postmortem

Issue: Disruption in SMS sending using Twilio Provider

Observation: We were getting invalid ssl error from the twilio provider called “ssl: certificate_verify_failed”

Root cause: The SSL certificate was updated by Twilio and our SMS provider was using the older certificate because of which we were getting invalid certificate error.

Fix: We migrated the customers from legacy Twilio provider to Lambda Twilio proivder where the certificates validation is not happening and everything is working fine.

Posted Dec 14, 2023 - 06:11 UTC

Resolved
The SSL certificate was updated by Twilio and our SMS provider was using the older certificate because of which we were getting invalid certificate error.
Posted Dec 12, 2023 - 18:00 UTC