SMS Magic readiness update - Salesforce Spring '24 release Updates
Incident Report for SMS Magic
Resolved
This incident has been resolved.

Affected customers need to contact sms magic customer support to get the org updated with a patch if they intend to enable LWS settings or if its already enabled and facing this issue.

More update from Salesforce:

Salesforce support has updated us that they have released patch fix for this issue in Sprint 24 Patch 8. Customers on patch8 will not need to upgrade sms-magic package, They should not face issues. (we are following with salesforce support for more updates)
Posted Feb 01, 2024 - 07:37 UTC
Monitoring
We are monitoring this for any issues with Salesforce Spring 24. We havent seen any other issues with Spring 24.
Posted Feb 01, 2024 - 07:34 UTC
Identified
For customers who want to test Spring 24 version, We have implemented the fix by commenting out the javascript code for showing tooltip in some conditions,It wont affect the product functionality. If they want to enable LWS settings, They can reachout to SMS magic support to get this patch or request a push upgrade from sms magic team for uninterrupted working of sms magic.

For other customers, We are actively following up with salesforce support to address this issue. We will keep you posted.
Posted Jan 31, 2024 - 19:30 UTC
Update
We are investigating the reason for the issue.

With Salesforce Spring '24 release, Salesforce has advised to enabled "Lightning Web Security" which can be enabled from the Setup of the Salesforce. This feature is disabled by default and if we enable the Lightning Web Security [LWS] (By clicking on the "Use Lightning Web Security for Lightning web components and Aura components" in session settings page under the Setup) causes the issues with the managed package functionality as mentioned by some of our customers on their sandbox orgs.


During investigation, our team found that one javascript related to showing tooltip on compose box, has been causing this issue. Although the Javascript code is syntactically & semantically right. Our team has raised issue with salesforce support for the same.

We have also observed that this issue occur on Salesforce spring 24 release patch 7. We have communicated this to salesforce support team and following up with them to provide fix salesforce team as well.
Posted Jan 31, 2024 - 08:30 UTC
Investigating
On 30th Jan 2024, Some of our Salesforce customers reported that functionality in our salesforce app - SMS Magic Converse, related to the messaging via UI and rendering of sender id step in converse settings wasn't working on their Salesforce sandbox preview orgs after they upgraded it to Salesforce Spring '24 and enabled Lightning Web Security flag in Sessions settings.

There was no impact observed on processes running in the background or automated messaging or any other features of the product.
Posted Jan 30, 2024 - 00:00 UTC
This incident affected: Salesforce Managed Package.