Incorrect Monthly Usage Reports (US DATA CENTER)

Incident Report for SMS Magic

Resolved

All reports have been regenerated and sent.
Posted Mar 24, 2026 - 09:20 UTC

Identified

SUMMARY
We identified an issue where incorrect monthly usage emails were sent to a majority of payee customers in the USA environment. The February usage report sent on March 7 contained incorrect credit counts due to a system glitch in the report generation process.

IMPACT
Customers who received the February usage email may have seen incorrect credit usage totals in their report. This issue affected email reports only and did not impact actual billing, account balances, or platform usage data.

CURRENT STATUS
We are currently regenerating the February usage reports with corrected data. Customers are advised to disregard the previous February usage email received earlier and refer to the corrected report once received.
Posted Mar 24, 2026 - 05:24 UTC
This incident affected: SMS Magic Australia Data Center (SMS Magic REST API, Salesforce API, Zoho API, Message Delivery Service, DLR Sync with Salesforce, Incoming Message Sync with Salesforce, DLR sync with Zoho, DLR sync with Open API, Incoming sync with Zoho, Incoming sync with Open API, Converse Desk on SaaS Portal, Incoming MMS messages processing, SMS Magic Customer Portal, Analytics Dashboard, SMS Magic Buy Portal, Incoming messages, Email Service, Billing & provisioning service, URL Shortening & Tracking) and SMS Magic Europe Data Center (SMS Magic REST API, Salesforce API, Zoho API, Message Delivery Service, DLR Sync with Salesforce, Incoming Message Sync with Salesforce, DLR sync with Zoho, DLR sync with Open API, Incoming sync with Zoho, Incoming sync with Open API, Converse Desk on SaaS Portal, Incoming MMS messages processing, SMS Magic Customer Portal, Analytics Dashboard, SMS Magic Buy Portal, Incoming messages, Email Service, Billing & provisioning service, URL Shortening & Tracking).