Delivery Issue US - US Cellular

Incident Report for SMS Magic

Resolved

End Time : 2025-12-19 14:20 UTC

We have received an update that the issue is now resolved.
Posted Dec 19, 2025 - 14:37 UTC

Investigating

Start Time : 2025-12-19 13:12 UTC

We have received a notification from our Provider regarding delivery issues in US - US Cellular.
Customers are facing Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will provide an update as soon as more information becomes available.
We apologize for the inconvenience and appreciate your patience.
Posted Dec 19, 2025 - 14:01 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).