Latency on Customer Portal
Incident Report for SMS Magic
Resolved
The Incident has been resolved.
Posted May 27, 2020 - 23:56 UTC
Update
We are continuing to investigate this issue.
Posted May 27, 2020 - 22:30 UTC
Investigating
We are observing latency on our Customer Portal. Pages are loading slower than usual. No Other Functionality is affected.

Our Engineering Team is investigating the issue currently.
Posted May 27, 2020 - 22:28 UTC
This incident affected: SMS Magic US Data Center (SMS Magic Customer Portal).