Carrier Partner Unplanned Maintenance - MMS

Incident Report for SMS Magic

Resolved

The scheduled maintenance has been completed.
If you continue to notice any discrepancy, please reach out to care@screen-magic.com
Posted Sep 25, 2025 - 14:38 UTC

Identified

Start Time: Sep 25, 04:00 UTC
Impact: Carrier Partner Unplanned Maintenance - MMS

Description:
The 10DLC delivery hub will be performing an unplanned maintenance September 24, 2025 at 11 PM CT. During this maintenance window, there may be intermittent latency for MMS.

Next Update: We will provide an update as soon as more information becomes available.
Posted Sep 24, 2025 - 17:29 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).