AT&T 10DLC MMS Duplicate Messages

Incident Report for SMS Magic

Resolved

This incident has been resolved.

Dec 04, 2025 - 05:27 UTC
Posted Dec 04, 2025 - 12:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2025 - 17:56 UTC

Investigating

Start Time : Dec 02, 2025 - 19:05 UTC

We have received a notification from our Provider regarding reports of duplicate messages being sent towards AT&T destinations on MMS routes. There is no duplication of messages at the Provider platform. The Engineering Team is working with the downstream partners to resolve the issue.

We will provide an update as soon as more information becomes available.
Posted Dec 02, 2025 - 19:27 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).