USA SMS - Delivery receipt degradation affecting a subset of Short Codes to multiple networks

Incident Report for SMS Magic

Resolved

This incident has been resolved.
End Time : Jun 22, 17:51 UTC
Posted Jun 22, 2026 - 18:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 17:21 UTC

Investigating

Start Time : Jun 22, 16:40 UTC
We have been notified about an issue impacting SMS messages from a subset of short codes to multiple networks. You may experience missing or delayed delivery receipts for a subset of short codes sending to multiple networks in the US.
We will issue an update as soon as more information becomes available.
Posted Jun 22, 2026 - 16:53 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).