Long Code Service Degradation - T-Mobile

Incident Report for SMS Magic

Resolved

The 10DLC delivery hub has confirmed the issue with T-Mobile has been resolved.
If you continue to notice any discrepancy, please reach out to care@screen-magic.com
Posted Sep 23, 2025 - 20:15 UTC

Identified

Start Time: Sep 22, 20:31 UTC
Impact: Long Code Service Degradation - T-Mobile

Description:
The 10DLC delivery hub has received notice of an issue resulting in intermittent delivery delays for MO/MT/DLR with T-Mobile.
We are following up with the provider and closely monitoring from our end.

Next Update: We will provide an update as soon as more information becomes available.
Posted Sep 22, 2025 - 20:48 UTC
This incident affected: SMS Magic US Data Center (Message Delivery Service).